Upgrading to TexLive 2017

I have just updated TexLive to 2017 version, this time installation went without issues.

I came to learn one can run tlmgr with a gui option, like,

tlmgr --gui -background white -foreground black -font "monaco 12"

Once I tried to compile the last work we did, I got the following error:

(/usr/local/texlive/2017/texmf-dist/tex/latex/fontspec/fontspec-luatex.sty
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!
/usr/local/texlive/2017/texmf-dist/tex/latex/fontspec/fontspec-luatex.sty:121: 
LaTeX error: "kernel/command-already-defined"
! 
! Control sequence \latinencoding already defined.
! 
! See the LaTeX3 documentation for further information.
! 
! For immediate help type H <return>.
!...............................................  

l.121 \tl_new:N \latinencoding

I filed an issue report, let’s see if it is a bug, or I am doing something wrong.

Update: It is a bug. The maintainer said the fix will be available by the end of the week.

tlcockpit

One nice new feature is tlcockpit (https://github.com/TeX-Live/tlcockpit)

In order to use it, onee needs to install java-fx

sudo pkg install openjfx8-devel
Password:
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
The following 2 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
	openjfx8-devel: 8.u172.b00_3,1
	swt-devel: 3.7.1_3,1

Number of packages to be installed: 2

The process will require 70 MiB more space.
15 MiB to be downloaded.